summaryrefslogtreecommitdiffstats
path: root/src/video/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/video/Makefile.am')
-rw-r--r--src/video/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/video/Makefile.am b/src/video/Makefile.am
new file mode 100644
index 0000000..27886e3
--- /dev/null
+++ b/src/video/Makefile.am
@@ -0,0 +1,14 @@
+noinst_LIBRARIES=libvideo.a
+
+libvideo_a_SOURCES = \
+ artpack.c explosion.c fonts.c fonttex.c gamegraphics.c \
+ graphics_fx.c graphics_hud.c graphics_lights.c \
+ graphics_utility.c graphics_world.c \
+ load_texture.c material.c model.c recognizer.c \
+ screenshot.c skybox.c texture.c trail.c trail_geometry.c \
+ trail_render.c video.c visuals_2d.c
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/lua/include \
+ -I$(top_srcdir)/nebu/include \
+ -I$(top_srcdir)/src/include